Latest versions:
Server plugin: 0.5.1
MVP dongle: 0.5.2
Raspberry Pi client: 0.5.2
Windows client: 0.5.2-1

Main Menu

Recent posts

VOMP for Raspberry Pi / Vompclient 0.5.2 on Raspberry4...
Last post by herb - February 06, 2022, 16:06:15

after I crashed with my little efforts to get into work the last version of the vomplient (0.5.2) on a rasp4B I wanted to know whether or not a port to the new hardware is planned.  I noticed that compiling the git version of the vompclient is possible using the last buster OS-version -  in the moment called Raspberry Pi OS Lite (Legacy). However the executable is crashing when the video module is initiated during CEC commmunication with the TV. So the GPU interface seems to be the problem.

See also the 2 debug files as output via

> vomplient -n -d

from a running raspi1B and a raspi4B.

Any answers are welcome!

VOMP General / MVP / Re: Compilation error of vomps...
Last post by winschrott - April 06, 2020, 07:59:19

sorry for my late response. The error is the following:

*** Plugin vompserver:
( if [ -f .standalone ] ; then ( rm -f .standalone; make clean ; make objects ) ; else exit 0 ;fi )
CC vompserver.o
g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -c -DPLUGIN_NAME_I18N='"vompserver"' -D__STL_CONFIG_H -DVOMPSERVER -I/home/administrator/vdr-2.2.0/include  -o vompserver.o vompserver.c
CC dsock.o
g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -c -DPLUGIN_NAME_I18N='"vompserver"' -D__STL_CONFIG_H -DVOMPSERVER -I/home/administrator/vdr-2.2.0/include  -o dsock.o dsock.c
CC dsock6.o
g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -c -DPLUGIN_NAME_I18N='"vompserver"' -D__STL_CONFIG_H -DVOMPSERVER -I/home/administrator/vdr-2.2.0/include  -o dsock6.o dsock6.c
dsock6.c: In member function 'bool DatagramSocket6::init(USHORT)':
dsock6.c:110:3: warning: 'auto' changes meaning in C++11; please remove it [-Wc++0x-compat]
   auto last = std::unique(mcastIndexes.begin(), mcastIndexes.end());
dsock6.c:110:8: error: 'last' does not name a type
   auto last = std::unique(mcastIndexes.begin(), mcastIndexes.end());
dsock6.c:111:22: error: 'last' was not declared in this scope
   mcastIndexes.erase(last, mcastIndexes.end());
dsock6.c:114:7: warning: 'auto' changes meaning in C++11; please remove it [-Wc++0x-compat]
   for(auto mif : mcastIndexes)
dsock6.c:114:12: error: 'mif' does not name a type
   for(auto mif : mcastIndexes)
In file included from /usr/include/x86_64-linux-gnu/sys/select.h:30:0,
                 from /usr/include/x86_64-linux-gnu/sys/types.h:219,
                 from /usr/include/stdlib.h:314,
                 from dsock6.c:21:
dsock6.c:129:3: error: expected ';' before 'do'
dsock6.c:129:3: error: expected primary-expression before 'do'
dsock6.c:129:3: error: expected ';' before 'do'
dsock6.c:129:3: error: expected primary-expression before 'do'
dsock6.c:129:3: error: expected ')' before 'do'
make[1]: *** [dsock6.o] Fehler 1

VOMP General / MVP / Re: Compilation error of vomps...
Last post by Chris - March 06, 2020, 12:15:32

Could you copy the build error messages here please. What operating system are you compiling on? How is it that you don't have IPv6?

VOMP for Raspberry Pi / Re: CEC functionality depends ...
Last post by winschrott - March 03, 2020, 18:47:36
Hello noone,

do you have the same problem with client 0.5.0 and later with the TV starting again after powering off when the RPI is connected via HDMI / CEC?
I didnĀ“t have this problem since client 0.4.x, but when I introduced the newer ones I got it. No change between hand-made image or the actual client-image. I tried the hdmi-ignore-cec-init-paramter without any change.

VOMP for Raspberry Pi / TV switches on again after tur...
Last post by winschrott - March 03, 2020, 18:42:52
Hello Chris,
hello Marten,

as in the earlier version of the RPI-Client (0.5.0) I have the same problem on my TV with the actual client-image:

But I found the following problems with the current git:

TV is restarting after power-off when connected by CEC and switched to the HDMI of RasPi (Panasonic TV / RasPi 3 with current firmware, 'hdmi_ignore_cec_init=1' in config.txt set so TV does not turn on when raspi starts).

The client seems to be more stable and has a longer timeout if the stream does not start immedeatly after program change (for example because of slow CW in connection with dvbapi). So the client does not get a connection lost.

Thans for your development!



VOMP General / MVP / Compilation error of vompserve...
Last post by winschrott - March 03, 2020, 18:37:27
I tried to compile the actual server 0.5.1 from GIT against VDR 2.2.0. I get errors in dsock6.c - is it because I do not have IPv6 installed on my VDR?

I changed the max. VOMP PROTOCOL VERSION in vompcientrrproc.c to 0x00000500.

Announcements / Version 0.5.2 released
Last post by Chris - January 23, 2020, 00:54:43
This is a minor bug-fix release affecting the client only, the server does not need updating and remains at version 0.5.1.

A new thing:

  • Radio recording resume

A fix:

  • Stopping and immediately resuming a recording fixed. In 0.5.1 it would start at the beginning


The Raspberry Pi image is now generated using Pi-Gen: The only difference you should notice is the new SSH user name: vomp, and password: vompian.

All the notes in the release announcement for 0.5.1 still apply.
VOMP for Raspberry Pi / Re: Static build possible?
Last post by noone - November 18, 2019, 07:02:41
Ha! that totally works. Just copied over every library to /lib on the vfat partition and booted with that as rootfs. Still having some issues with fonts (everything is monospaced) but I will post a ZIP which conaints all files for a blank sdcard with only a fat partition.
VOMP for Raspberry Pi / Re: CEC functionality depends ...
Last post by noone - November 15, 2019, 20:37:53
I finally found the problem! =)
A feature introduced in a later raspberry firmware than I used which turns on your tv seems to disable some buttons on the remote on my panasonic tv.

Using hdmi_ignore_cec_init=1 in /boot/config.txt fixes the problem completely, yesss!!
Announcements / Version 0.5.1 released
Last post by Chris - October 29, 2019, 19:49:14
New things:

  • It's now possible to mark as recording as new (deleting the resume data)
  • The recording information screen displays more details
  • When playing a recording, the "previous channel" button rewinds 2s (for interlacing resync (yes, this needs fixing properly))
  • IPv6 support (Raspberry Pi only)


  • Fixed a playback hang due to a threading deadlock
  • Fixed a hang starting playing a recording which has already been deleted on the server
  • Fixed the Raspberry Pi screen going black during pause
  • Fixed a bug moving a recording with special characters in the name
  • Fixed a bug with the advanced menu in options
  • Fixed the stop-time display in the timer information screen
  • Compile fixes for Stretch and Buster
  • Fixed libcec4 support
  • Saved some Raspberry Pi CPU usage in the on-screen-display code
  • Fixed a crash when using subtitles
  • Fixed a crash pressing up too much in the options screen


  • Server Makefile updated
  • Server sample config file updated


The minimum VDR version is still 1.7.35. The maximum known-working version is 2.4.1.

Raspberry Pi models 1, 2 and early 3s are known to work. Later Pi 3s did not work with the 0.5.0 image but I expect they will work with 0.5.1. I haven't got a late 3, if you have and it works please let me know.

Reportedly the Raspberry Pi 4 has no hardware MPEG2 support. I haven't got a Pi 4 so I can't test it. I expect very bad results trying to play MPEG2! It might still work to play MPEG4, I don't know. It is also possible the image won't work at all - reports welcome!

This is probably the last 0.5.x release. 0.6.x will drop support for Hauppauge MVPs and will require at minimum VDR 2.4.0.