Recent Posts

Pages: 1 [2] 3 4 ... 10
VOMP for Raspberry Pi / Re: Option Advanced Menu not working properly
« Last post by kowovomp on January 14, 2018, 21:34:39 »
sourcefile VOPTS.CC needs to be corrected:

WRONG: option = new Option(19, "Advanced Menu", "General", "Menu type",Option::TYPE_TEXT, 2, 0, 0, options19);
CORRECT: option = new Option(19, "Advanced Menu", "Advanced", "Menu type",Option::TYPE_TEXT, 2, 0, 0, options19);
VOMP for Raspberry Pi / Re: Option Advanced Menu not working properly
« Last post by kowovomp on January 14, 2018, 19:07:57 »
I've found the error  ;D

The client tries to load the option from the ADVANCED section, but it's saved to GENERAL.
As a workaround i've moved the "Menu type = Classic" parameter in the conf-file to the correct section.

VOMP for Raspberry Pi / [solved] Option Advanced Menu not working properly
« Last post by kowovomp on January 11, 2018, 21:48:23 »

the 0.5.0 image is running well, but the "advanced menu" option is not working properly.

I would like to stay with "classic" menu, that works fine until i restart the raspberry.
after a reboot the option ist still set to "classic", but the skin looks like "advanced".
if i set the option to advanced and back to classic, it's fine again.

the option is also saved correct in <MAC>.conf file as "Menu type = Classic".

Thanks for help,
VOMP for Raspberry Pi / Sleeptimer and volume at startup
« Last post by kaiserbene1 on November 19, 2017, 21:49:57 »

is there any way to activate a sleeptimer to avoid the tv running the whole night while sleeping in front of it? I love vomp running on my pi having hd streams - but i remember there was a function like this on the mvp - so any solutions for this topic?
also the volume is at 100% when starting up the pi - can this be reduced in any way?

Thanks for any advice...


(vomp 0.5 looks awesome - thanks for the graphic redesign)
VOMP General / MVP / Re: Media MVP is not starting
« Last post by JR.VOY on October 03, 2017, 07:37:27 »
Thank you
Hi there,

to avoid splitting of recordings I run vdr with a relatively large value for MaxVideoFileSize. This lead to issues within RecPlayer::scan and getBlock as fseek and ftell are limited to a file size of 4GB. Replacing them with their fseeko and ftello counterparts fixes this for me - patch attached.

Excellent thanks for the patch Alex.
VOMP General / MVP / VOMP 0.5.0 Installation
« Last post by eed01 on April 27, 2017, 06:37:19 »
i just compiled and installed the vompserver plugin on a Ubuntu 16.04 LTS System.
Ubuntu comes with VDR 2.2.0 but no vompserver plugin available

Some remarks to the installation:

- vomp.conf must be copied to /etc/vdr/conf.avail and symlinked from /etc/vdr/conf.d  (e.g. 50-vomp.conf)
- [General] in the file vomp.conf has to be replaced by [vompserver]. VDR seems to generate the plugin name it wants to load from this string

Announcements / Version 0.5.0 released
« Last post by Chris on March 15, 2017, 17:31:58 »
After the longest development delay yet.. VOMP 0.5.0 is finally finished!

New things:

  • Improved EPG and recordings menu
  • Poster, cast and banner picture through scraper2vdr support
  • TV station logos
  • Scrollable EPG texts
  • Different skins (noOpacity inspired and two classic skins) - different color schemes
  • TVBD inclusion through scraper2vdr
  • Uses audio and subititle presets from VDR settings
  • Mouse wheel support (Windows)
  • High resolution vector based OSD (Windows)
  • Support for Raspbian Jessie
  • Experimental support for VDR 2.3.1/2
  • Experimental new SD card image for Raspberry Pi


  • Several crashes, lock-ups and memory leaks have been fixed
  • Fixes for compatibility with newer Raspbery Pi firmware

Other notes:

The minimum VDR version is 1.7.35, the maximum is 2.2.0 but it may work with 2.3.1 and 2.3.2.

Raspberry Pi models 1 and 2 are known to work. If you run it on a 3 let us know how it goes.

The SD card download is a new and experimental feature. Please let me know of any problems, or even success stories!

The MVP is still supported for this release, but this is most likely the last version to support it.
VOMP for Raspberry Pi / Vompclient crashes
« Last post by TEDDYXXL on December 26, 2016, 13:10:33 »
Hi !

After updating to latest git version of rasppi-vompclient vompclient crashes during select recordings:

13:10:50.304505 [debug]  RRProc - thread woken with req, queue size: 1
13:10:50.304527 [debug]  RRProc - TVMedia request 133 /video0/Hunde_haben_kurze_Beine/2006-12-
13:10:50.304530 [debug]  PictRead - Got TVMediaRequest, signal thread!
13:10:50.304542 [debug]  RRProc - threadMethod waiting
13:10:50.305693 [debug]  PictRead - Load Pict
13:10:50.305704 [debug]  PictRead - Request 0 0;  3 1 0 0
13:10:50.306430 [debug]  Client - Received chan=1, ser=134, op=42, edl=79
13:10:50.306442 [debug]  RRProc - recvReq
13:10:50.306447 [debug]  RRProc - recvReq set req and signalled
13:10:50.306449 [debug]  Client - Waiting
13:10:50.306467 [debug]  RRProc - thread woken with req, queue size: 1
13:10:50.306493 [debug]  RRProc - TVMedia request 134 /video0/Beethoven_III_-_Ein_Urlaub_mit_Hindernissen/2006-12-
13:10:50.306497 [debug]  PictRead - Got TVMediaRequest, signal thread!
13:10:50.306510 [debug]  RRProc - threadMethod waiting
13:10:50.312338 [debug]  PictRead - Load Pict
13:10:50.312349 [debug]  PictRead - Request 0 0;  3 1 0 0
13:10:50.318941 [debug]  PictRead - Load Pict
13:10:50.318951 [debug]  PictRead - Request 0 0;  3 1 0 0
13:10:50.325477 [debug]  PictRead - Load Pict
13:10:50.325486 [debug]  PictRead - Request 0 0;  3 1 0 0
13:10:50.331976 [debug]  PictRead - Load Pict
13:10:50.338800 [ERR]    Client - Incoming channel number unknown
13:10:50.338810 [debug]  Client - Vomp client destructor
13:10:50.338920 [debug]  TCP - TCP has closed socket
13:10:50.338950 [info]   RRProc - threadMethod err 2 or quit

My vompserver-version runs on linux-server (opensuse leap 42.2):

Dez 26 13:26:38 pcneu vdr[26376]: [26376] initializing plugin: vompserver (0.4.1): Vompserver plugin by Chris Tallon


VOMP for Raspberry Pi / Output ext. Soundcard
« Last post by tramCS on August 22, 2016, 08:47:32 »

I have an older AVR-Receiver without HDMI-Inputs. I have connected a soundcard for my client with a digital output.
Can i set the sound-output at the vompclient to this ext. soundcard ?

The vompclient-settings regarding the soundoutput shows only "HDMI or analog".


Pages: 1 [2] 3 4 ... 10