Recent Posts

Pages: 1 2 [3] 4 5 ... 10
VOMP for Raspberry Pi / Re: vompclient 0.5 features
« Last post by Chris on May 09, 2018, 15:07:04 »
Hi ralph, it's good to hear from someone still using vomp! Now if only the forum notify system had worked it wouldn't have taken me so long to read your message... Oops!

I have just tried to compile vompclient on a fresh Raspbian Stretch and yes, you're right it needs some attention. It is possible but really the downloads and documentation need updating to support it OOTB.

So, in answer to your questions:

1. How you describe is exactly how I use vomp - lircd with uinput events. Since I don't use that Pi's console for anything else, vomp is always hiding the login prompt with the strange characters so it's not really a problem. The strange characters are caused by the kernel's /dev/input system taking the characters that lircd-uevent gives it and handing it to the console as keyboard input. Since the remote buttons are never going to get past the login prompt it's an ignorable problem... Having said that I did once have a quick look into whether it is possible to have the kernel be selective about which input devices it uses for console keyboard input but I didn't find a way. Perhaps there is a way to "consume" the key press... Maybe a bit more digging around would find a way. I would rather not change to support lirc directly because the current system of using /dev/input enables lirc, USB IR receivers and real keyboards simultaneously.

2. As I said above, it is possible but with the following modifications to the instructions on the web site. The packages need to be altered like this:

Code: [Select]
sudo apt-get install libcec-dev libcec4=4.0.1+dfsg1-1+rpi1 libavresample-dev
This installs an old version of libcec. I still need to see if the later version works.

The git clone needs to be at HEAD, not "-b 0.5.0", as there are patches in there to enable compiling on stretch.

Also on my installation I need the following extra line in

Code: [Select]
@@ -86,6 +86,8 @@ int VideoOMX::init(UCHAR tformat)
   if (initted) return 0;
   initted = 1;

+ bcm_host_init();

I was communicating with Marten Richter about this but I haven't done the fix properly yet. I think he recommended a better place for that line.

After all this, it compiles and works.

3. When I made the last release I tried rolling forward my VDR version as far as possible. I got to 2.2.0 which worked. 2.3.1 broke all four of my VDR plugins and was therefore a step too far. I will have to work on this.

4. Erm, good questions. We should write something on the VDR Wiki.

5. If I remember correctly it was Marten Richter who created the Debian integration. I'm sorry, I hadn't considered those files at all when I made the last release - I've not been near them. This needs work.

6. Yes! What do you want to tackle first? ;)

7. Apparently not! I've always run vomp on single purpose Pis so it running as root hasn't been an issue. I had assumed that all the hardware access would require root permissions but it seems not. There is some code around VT switching that fails when not run as root but it doesn't seem to be making a difference. I will ask Marten what that does.

Having looked at all this in response to your message I think it's definitely time to re-base on Stretch and get a 0.5.1 released, and soon.
VOMP for Raspberry Pi / vompclient 0.5 features
« Last post by ralph on March 11, 2018, 19:59:35 »
Hi vomp developers,

I just noticed that there has been a new release of vomp for RPI. Thx a lot for that :D. I am with vomp since more than 10 years now and it is still the best vdr streaming solution out there.

I tried to find answers to various question about the release but it is rather silent around vomp nowadays. I checked vdr-wiki, vdr-portal and the git for information. It seems most people rely on Kodi, which in my opinion is not suitable for the performance of a RPI. I also checked the git logs and got some ideas, while I am unsure in some aspects. Perhaps the developers would like to give some information on the release:
  • Is lirc supported now? I was using the lircd creating uinput events, but this also caused the console to show a lot of strange characters. Direct usage of lirc would be the better solution imho. CEC is not working for me as my TV does not support the forwarding of remote control events.
  • Is it possible to compile on Raspbian Stretch? I saw some commits regarding stretch, but is it working ootb with updated CEC and FFMPEG versions?
  • Is the server plugin also working with vdr 2.3.x? Latest Ubuntu versions seem to ship now with 2.3.x. Any experiences?
  • Is it planned to provide some information at the vdrwiki, in the vdr portal or at least as a readme? The marketing of vomp is rather modest. Or are no new users wanted?
  • Is there a chance to get a Debian package being built? The debian tree is currently reflecting the version 0.4.2 as head. Perhaps this can be updated. Also, the system integration is based on init and not systemd. This is a little outdated for jessie and stretch. Are there somewhere updates around already?
  • Are contributions welcome? In which way? I did not see the possibility to add myself as a developer. At least at the packaging point or by writing a readme I should be able to contribute a little.
  • Is root really needed to run vompclient? I was running vompclient 0.4.1 always without root and never observed any trouble.

Thx for any further information provided.
VOMP for Raspberry Pi / Re: [solved] Option Advanced Menu not working properly
« Last post by MartenR on January 15, 2018, 07:16:08 »
Thanks for reporting this.
I have added your fix to the git.

VOMP for Raspberry Pi / Re: Option Advanced Menu not working properly
« Last post by kowovomp on January 14, 2018, 21:34:39 »
sourcefile VOPTS.CC needs to be corrected:

WRONG: option = new Option(19, "Advanced Menu", "General", "Menu type",Option::TYPE_TEXT, 2, 0, 0, options19);
CORRECT: option = new Option(19, "Advanced Menu", "Advanced", "Menu type",Option::TYPE_TEXT, 2, 0, 0, options19);
VOMP for Raspberry Pi / Re: Option Advanced Menu not working properly
« Last post by kowovomp on January 14, 2018, 19:07:57 »
I've found the error  ;D

The client tries to load the option from the ADVANCED section, but it's saved to GENERAL.
As a workaround i've moved the "Menu type = Classic" parameter in the conf-file to the correct section.

VOMP for Raspberry Pi / [solved] Option Advanced Menu not working properly
« Last post by kowovomp on January 11, 2018, 21:48:23 »

the 0.5.0 image is running well, but the "advanced menu" option is not working properly.

I would like to stay with "classic" menu, that works fine until i restart the raspberry.
after a reboot the option ist still set to "classic", but the skin looks like "advanced".
if i set the option to advanced and back to classic, it's fine again.

the option is also saved correct in <MAC>.conf file as "Menu type = Classic".

Thanks for help,
VOMP for Raspberry Pi / Sleeptimer and volume at startup
« Last post by kaiserbene1 on November 19, 2017, 21:49:57 »

is there any way to activate a sleeptimer to avoid the tv running the whole night while sleeping in front of it? I love vomp running on my pi having hd streams - but i remember there was a function like this on the mvp - so any solutions for this topic?
also the volume is at 100% when starting up the pi - can this be reduced in any way?

Thanks for any advice...


(vomp 0.5 looks awesome - thanks for the graphic redesign)
VOMP General / MVP / Re: Media MVP is not starting
« Last post by JR.VOY on October 03, 2017, 07:37:27 »
Thank you
Hi there,

to avoid splitting of recordings I run vdr with a relatively large value for MaxVideoFileSize. This lead to issues within RecPlayer::scan and getBlock as fseek and ftell are limited to a file size of 4GB. Replacing them with their fseeko and ftello counterparts fixes this for me - patch attached.

Excellent thanks for the patch Alex.
VOMP General / MVP / VOMP 0.5.0 Installation
« Last post by eed01 on April 27, 2017, 06:37:19 »
i just compiled and installed the vompserver plugin on a Ubuntu 16.04 LTS System.
Ubuntu comes with VDR 2.2.0 but no vompserver plugin available

Some remarks to the installation:

- vomp.conf must be copied to /etc/vdr/conf.avail and symlinked from /etc/vdr/conf.d  (e.g. 50-vomp.conf)
- [General] in the file vomp.conf has to be replaced by [vompserver]. VDR seems to generate the plugin name it wants to load from this string

Pages: 1 2 [3] 4 5 ... 10