Author Topic: need a new vomp-dongle-0.4.0  (Read 6154 times)

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
need a new vomp-dongle-0.4.0
« on: February 26, 2013, 17:52:34 »
Hi,

I need a new vomp-dongle-0.4.0

HDTV with a filter in vdr.cc
Code: [Select]
--- a/vdr.cc
+++ b/vdr.cc
@@ -818,7 +818,7 @@ ChannelList* VDR::getChannelsList(ULONG type)
     chan->name = vresp->extractString();
     chan->vstreamtype = vresp->extractULONG();
 
-    if (chan->type == type && ((chan->vstreamtype==0x1b && h264support)|| mpeg2support) )
+    if (chan->type == type && ((chan->vstreamtype==0x1b && h264support)|| (chan->vstreamtype!=0x1b &&mpeg2support)) )
     {
       chanList->push_back(chan);
       logger->log("VDR", Log::DEBUG, "Have added a channel to list. %lu %lu %s", chan->number, chan->type, chan->name);

can someone create a dongle MediaMVP with this patch?

regards
tvia

Offline sirwio

  • Full Member
  • ***
  • Posts: 117
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #1 on: February 27, 2013, 15:08:18 »
Only quick smoke test done of the build. The mvp boot and will not show hd channels in the channel list.

http://ubuntuone.com/2v5NGFb6ogypJYhS0aI5TR

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #2 on: February 27, 2013, 18:49:42 »
very good work - going well

has anyone had to shutdown patch for MVP for version 0.4.0

regards
tvia

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #3 on: February 27, 2013, 20:51:37 »
it would be possible to create a dongle with vdrshutdown?

Download
- http://www.sc-schulze.de/wp-content/downloads/cinfo/vompclient-vdrshutdown-0.4.0.tar.bz2

regards
tvia

Offline Chris

  • Administrator
  • Hero Member
  • *****
  • Posts: 537
    • View Profile
    • Email
Re: need a new vomp-dongle-0.4.0
« Reply #4 on: March 02, 2013, 16:18:31 »
Hi, for the shutdown patch could you do the following to your vompserver plugin source:

Code: [Select]
git fetch
git checkout fd3282b02ddf35e5a33cd0df9c84135b7d98798a

Make plugins as usual. Then try this dongle with it: http://www.loggytronic.com/dl/vomp-dongle-0.4.1-dev1

My VDR refuses to shutdown but it knows the VDR power button has been pressed. Does it work for you?

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0/0.4.1
« Reply #5 on: March 02, 2013, 20:10:29 »
Hi,

MVP-Dongle =
Quote
protocoll mismatch s: 200 c:301

hmm, with vompserver 0.4.1 (git) ---  maybe I have a bug


regards
tvia
« Last Edit: March 02, 2013, 20:15:20 by TVIA »

Offline Chris

  • Administrator
  • Hero Member
  • *****
  • Posts: 537
    • View Profile
    • Email
Re: need a new vomp-dongle-0.4.0
« Reply #6 on: March 02, 2013, 20:14:22 »
Did you recompile the plugin? That message indicates the server is still on 0.4.0.

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #7 on: March 02, 2013, 20:16:25 »
Hi,

yes I do

tvia

Offline Chris

  • Administrator
  • Hero Member
  • *****
  • Posts: 537
    • View Profile
    • Email
Re: need a new vomp-dongle-0.4.0
« Reply #8 on: March 02, 2013, 20:22:18 »
Hi, go to your vompserver plugin source directory and run this:

Code: [Select]
grep VOMP_PROTOCOL_VERSION *

You need to see

Code: [Select]
vompclientrrproc.c:ULONG VompClientRRProc::VOMP_PROTOCOL_VERSION = 0x00000301;
Did you get the plugin by tar.gz or by git in the first place?

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #9 on: March 02, 2013, 20:43:28 »
OK, my mistake - was my version of yesterday vompserver
Now I'll test

The MVP can start the VDR, too?

regards
tvia

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #10 on: March 02, 2013, 20:47:36 »
hi,

vdrshutdown is working and VDR can start --- perfectly so it should work  :D

regards
tvia


Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #11 on: March 02, 2013, 22:48:33 »
Hi,

I would like to create myself a dongle but unfortunately I always get the error on lenny

makedevenv (last git-version)

crosstool
Code: [Select]
DEJAGNU not set, so not running any regression tests
GLIBC_ADDON_OPTIONS not set, so building all glibc add-on's
KERNELCONFIG not set, so not configuring linux kernel
+ TOOLCOMBO=gcc-3.4.5-glibc-2.2.5
++ pwd
+ BUILD_DIR=/home/mvp/crosstool/crosstool-0.43/build/powerpc-405-linux-gnu/gcc-3.4.5-glibc-2.2.5
++ pwd
+ TOP_DIR=/home/mvp/crosstool/crosstool-0.43
+ test -z ''
+ SRC_DIR=/home/mvp/crosstool/crosstool-0.43/build/powerpc-405-linux-gnu/gcc-3.4.5-glibc-2.2.5
+ echo 'SRC_DIR not set, so source tarballs will be unpacked in the build directory'
SRC_DIR not set, so source tarballs will be unpacked in the build directory
+ case x$PREFIX in
+ case x$USER in
+ abort 'Don'\''t run all.sh or crosstool.sh as root, it'\''s dangerous'
+ echo 'Don'\''t' run all.sh or crosstool.sh as root, 'it'\''s' dangerous
Don't run all.sh or crosstool.sh as root, it's dangerous
+ exec false

kernel
Code: [Select]
scripts/split-include include/linux/autoconf.h include/config
gcc -D__KERNEL__ -I/home/mvp/kernel/dongle/linux-2.4.31/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -fomit-frame-pointer -I/home/mvp/kernel/dongle/linux-2.4.31/arch/ppc -fsigned-char -msoft-float -pipe -ffixed-r2 -Wno-uninitialized -mmultiple -mstring -Wa,-m405   -DKBUILD_BASENAME=main -c -o init/main.o init/main.c
cc1: error: unrecognized command line option "-mmultiple"
cc1: error: unrecognized command line option "-mstring"
cc1: warning: unknown register name: r2
as: Unbekannte Option »-m405«
make: *** [init/main.o] Fehler 1

@Chris
Hmm, you could also help here?

regards
tvia

Offline Chris

  • Administrator
  • Hero Member
  • *****
  • Posts: 537
    • View Profile
    • Email
Re: need a new vomp-dongle-0.4.0
« Reply #12 on: March 03, 2013, 01:04:48 »
Well as for building crosstool under the root user, it doesn't work and you shouldn't be doing that :)

For the kernel I have no idea, I don't recognise those errors. But if your crosstool failed you can't surely be compiling anything else??

What is your shell?

Are you definitely running lenny? Sure it used to work on lenny and I don't know why it wouldn't now, but still...

Offline TVIA

  • Jr. Member
  • **
  • Posts: 14
    • View Profile
Re: need a new vomp-dongle-0.4.0
« Reply #13 on: March 03, 2013, 10:38:43 »
hi,

ok now works without any errors - we'll see if the MVP start up

tvia

Offline Chris

  • Administrator
  • Hero Member
  • *****
  • Posts: 537
    • View Profile
    • Email
Re: need a new vomp-dongle-0.4.0
« Reply #14 on: March 03, 2013, 12:58:43 »
If you use vomp to shut down vdr in this way, how does vdr start up again?