Author Topic: vompserver 0-4-0rc client compatibility  (Read 2522 times)

Offline sirwio

  • Full Member
  • ***
  • Posts: 117
    • View Profile
vompserver 0-4-0rc client compatibility
« on: January 22, 2013, 17:37:14 »
I makings some test using the vompserver 0-4-0rc branch. My raspi client compiled from 0-4-0rc branch will connect to the vompserver but my old mvp client running 0.3.1 will not.

Do I have anything miss configured or is is a fact that the new protocol and/or new discovery protocol is not compatible with old vomp clients?

Offline Chris

  • Administrator
  • Hero Member
  • *****
  • Posts: 537
    • View Profile
    • Email
Re: vompserver 0-4-0rc client compatibility
« Reply #1 on: January 22, 2013, 21:08:28 »
Yes it is different, you can't use a 0.3.1 client with 0.4.0rc server. You would need to match the versions. The release is soon, I'm just fixing a few bugs..

Offline Harry

  • Full Member
  • ***
  • Posts: 168
    • View Profile
Re: vompserver 0-4-0rc client compatibility
« Reply #2 on: February 22, 2013, 16:56:37 »
brutal patching in order to force different versions of
client/server to connect is not advisable i presume?

Offline MartenR

  • Hero Member
  • *****
  • Posts: 788
    • View Profile
Re: vompserver 0-4-0rc client compatibility
« Reply #3 on: February 23, 2013, 08:51:22 »
Yes it is not advisable.

Marten