Author Topic: My first time with vomp  (Read 4334 times)

Offline dreamlomax

  • Jr. Member
  • **
  • Posts: 3
    • View Profile
My first time with vomp
« on: April 26, 2010, 01:45:40 »
Hi everybody,
I was using mvmpc, but I was testing VDR and I found this related project.

I installed a binary vdr-plugin-vomp version from the next ppa (ubuntu):

    https://launchpad.net/~the-vdr-team/+archive/vdr-ubuntu-karmic/+index?start=150&batch=75

I'm using vdr-1.7.10-10yavdr1 from the same ppa.

With mvmpc I was using atfpd and dhcpd, but I have some problems while I testing vomp, and finally prefered use all native
from this. Finally I saw how the Mediamvp boots from Vomp, but after get configuration I see in TV an error that says "losed connection".
Here lines from vomp server:

Quote
17:00:53.135395 [debug]  Config - Opened config file: /var/lib/vdr/plugins/vompserver/vomp-00-0D-FE-00-36-EF.conf
17:00:53.135439 [debug]  RRProc - written login reply len 20
17:00:53.135458 [debug]  RRProc - threadMethod waiting
17:00:53.197012 [debug]  Client - Received chan=1, ser=33, op=12, edl=17
17:00:53.197066 [debug]  RRProc - recvReq set req and signalled
17:00:53.197095 [debug]  Client - Waiting
17:00:53.197103 [debug]  RRProc - thread woken with req, queue size: 1
17:00:53.197228 [debug]  RRProc - Written config load packet
17:00:53.197275 [debug]  RRProc - threadMethod waiting
17:00:53.198351 [debug]  Client - Received chan=1, ser=34, op=33, edl=0
17:00:53.198384 [debug]  RRProc - recvReq set req and signalled
17:00:53.198411 [debug]  Client - Waiting
17:00:53.198412 [debug]  RRProc - thread woken with req, queue size: 1
17:00:53.199269 [debug]  RRProc - threadMethod waiting
17:00:53.200506 [debug]  Client - Received chan=1, ser=35, op=34, edl=3
17:00:53.200536 [debug]  RRProc - recvReq set req and signalled
17:00:53.200563 [debug]  Client - Waiting
17:00:53.200566 [debug]  RRProc - thread woken with req, queue size: 1
17:00:53.202322 [debug]  RRProc - threadMethod waiting
17:00:53.298969 [debug]  Client - Received chan=1, ser=36, op=12, edl=25
17:00:53.299070 [debug]  RRProc - recvReq set req and signalled
17:00:53.299096 [debug]  Client - Waiting
17:00:53.299278 [debug]  RRProc - thread woken with req, queue size: 1
17:00:53.299435 [debug]  RRProc - Written config load packet
17:00:53.299492 [debug]  RRProc - threadMethod waiting
17:00:53.300668 [ERR]    Client - Incoming channel number unknown
17:00:53.300697 [debug]  Client - Vomp client destructor
17:00:53.300760 [debug]  TCP - TCP has closed socket
17:00:53.300808 [info]   RRProc - threadMethod err 2 or quit

I tried with remote say try again, but all the time get configuration and lose connection.
The dongle that I used is from last version that I saw in the forum 0.3.1-3-Yaris.

Do anybody known what happens?

Some info and comments:
  I'm testing with ubuntu 9.10 VDR backend. VDR it's working fine because i'm using from an external computer with xbmc.

Some problems during installation:
 - I should add some config values to vomp-..conf based on errors in log, searching in source code when are printed errors, and some from google, but i think that possible the config example vomp-00-...conf needs to be completed with all available parameters/arguments. I try to find documentation, but I dont find anything, exist some docs about the available configs or where I can find more info about full features?
I read in forum for example something about .sh scripts that allows execute in vdr commands, for example for try to play with mplayer for play avi's, but i'm dont know if in vomp configuration file should be added a section or if it is depending on vdr part.

I hope see soon the vomp on my children TV
Thanks a lot :-D

Offline MartenR

  • Hero Member
  • *****
  • Posts: 789
    • View Profile
Re: My first time with vomp
« Reply #1 on: April 26, 2010, 16:03:47 »
I would suspect that the vdr-plugin-vompserver and the dongle have another version.
The error is typical for a protocoll mismatch.

Marten

Offline dreamlomax

  • Jr. Member
  • **
  • Posts: 3
    • View Profile
Re: My first time with vomp
« Reply #2 on: April 26, 2010, 19:47:55 »
In yadr repository i don't find the dongle file.


I tried some days ago compile from 0.3.1-3-Yaris but i see a warning about binary "incompabitle" or similar when start VDR and didn't start. Finaly i prefered use the repository version that init with vdr correctly.

Can you give more info about versions or compile it correctly without this warning?

Thanks for you comments :-D

Offline MartenR

  • Hero Member
  • *****
  • Posts: 789
    • View Profile
Re: My first time with vomp
« Reply #3 on: April 27, 2010, 15:59:44 »
Quote
Finaly i prefered use the repository version that init with vdr correctly.
Well then find out the version of the installed plugin and get the dongle from this site with the same version.

Marten

Offline dreamlomax

  • Jr. Member
  • **
  • Posts: 3
    • View Profile
Re: My first time with vomp
« Reply #4 on: May 22, 2010, 23:37:35 »
HI,
finally i compiled some more times and finally the last dongle version from yaris is working fine :-D

Some problems with test1.sh, I think that in repository and in source code is not updated with last version from
http://www.wellenvogel.de/software/vomp/, possible some body can update it and possible update media options in vomp.conf.sample,
because is hard know how to configure.

Some problems with the 4/3 Flat TV, because videos 16/9 are very wide but is working fine

Thanks, I think think that now my Hauppage mvp has a new alive time :-D.