Author Topic: Tumbleweed  (Read 4512 times)

Offline Chris

  • Administrator
  • Hero Member
  • *****
  • Posts: 537
    • View Profile
    • Email
Tumbleweed
« on: October 24, 2008, 13:18:13 »
Oooh, quiet in here...

Offline Harry

  • Full Member
  • ***
  • Posts: 168
    • View Profile
Re: Tumbleweed
« Reply #1 on: October 24, 2008, 15:56:51 »
well, we're all happy with what we have  ;)

happy weekend 2 all
Harry

Offline davep

  • Full Member
  • ***
  • Posts: 169
    • View Profile
Re: Tumbleweed
« Reply #2 on: October 24, 2008, 16:40:20 »
The requirement for KDE4 is what puts me off. Maybe I'll have a play in a virtual machine sometime.

Offline muellerph

  • Full Member
  • ***
  • Posts: 136
    • View Profile
    • Email
Re: Tumbleweed
« Reply #3 on: October 24, 2008, 17:47:38 »
I know, KDE4 is a hindering factor.

But if you want to try another way (I didn't yet), it may work following way:
- Install Qt 4.4
- Get the Phonon soucecode from KDE trunc (and only the phonon module, it is in kdesupport)
- Just compile the phonon module out of kdesupport
- Replace the phonon libs and the backend libs of Qt 4.4 with the kdesupport phonon libraries.

In KDE trunk, the xine backend has no more dependency on KDE anymore, so it just compiles with Qt 4.4 (for me it did)

What I don't know if there are changes in Phonon itself which would make KDE Phonon not work together with Qt 4.4
But based on the structure I've seen so far, it should not make any troubles.

This last step I will try at home soon. If it works I will post here the steps and also update the INSTALL instructions.