Latest versions:
Server plugin: 0.5.1
MVP dongle: 0.5.2
Raspberry Pi client: 0.5.2
Windows client: 0.5.2-1

Main Menu

Audio out of sync

Started by sirwio, March 04, 2013, 15:24:15

Previous topic - Next topic


I noticed on some channels especially HD channels that audio is out of sync (poor lip-sync). Made a recording and tested playback using streamdev and the new samsung smart tv app and playback is correct.

Copied the recording locally to the raspberry where I tested playback using omxplayer with the same result. But when omxplayer was started with --refresh argument the playback is correct with proper lip-synch.

The option --refresh does adjust the framerate/resolution to the video.
>   -r / --refresh                 adjust framerate/resolution to video

I noticed the omxplayer said it adjusted to mode 31 so I changed /boot/config.txt to startup at that resolution. Rebooted and playback was then ok using omxplayer without the --refresh argument. But playback using vompclient is still with poor lip-sync.

Any suggestions on how one can get proper playback/live tv with lip sync?


This sounds like a problem with the TV firmware or raspberry firmware. There is little we can do.
Maybe you should contact dom in the raspberry pi forum, he might be able to fix such issues in the firmware.

The doing something like the refresh option is no option for me since handling with the osd is a problem.

You should note, that vomp changes the framerate on his own, so it might be that your option in boot.txt is ignored.
Look in the vomp log what it says about "Found native mode" and "Found optimum mode" and ""Switch to prefered mode".
(If you have a FullHD tv vomp should select mode 31 anyway).

One difference might be, that vomp uses the deinterlacer as default, may be turning it off helps.



Setting the Advanced option "SD Deinterlacing" to "None" did improve playback.

With the setting set to "Advanced" I got the following while playback of the troublesome recording:

16:03:37.227910 [notice] 2312 Video - VideoType 1920 x 1080 i: 1
16:03:37.229401 [notice] 2312 Video - Deinterlacing activated 2

Whilst with the setting "None" one only gets the first line.

I can pm you a downloadable link to a snippet of the recording in case you want to check it out. Note that the poor lipsync behaviour is not noticed on all 1920x1080i broadcasts but only on some.


I have looked at it.
The picture is a bit difficult to interpret.
It does have a constant time offset.
Sometimes the lips are completely in sync, then they are slightly out of sync until, they are again in sync. (I did not spot a difference in deinterlacer turned off and on).
What I am not sure about, if the source is perfectly in sync the movie sniplet might been cutted separately on audio and video.

Anyway, it can be some kind of buffering problem related to a high bit rate.
I will fiddle a bit around with the buffers.



I have the idea, that it can be a bug in the audio decompression code.
If your tv is cable, can you please set AC3 over HDMI to ac3.
If the problems are gone, than I know were the problem is.



Yes setting the "AC3 HDMI Mode" setting from "PassThrough" to "PCM" did improve playback as well even with "SD Deinterlacing" set to "Advanced".

Not sure if that was the setting you meant:
> If your tv is cable, can you please set AC3 over HDMI to ac3.

My broadcast is DVB-S2

I will test over the weekend to find other shows that show the same errors - perhaps some less chezzy clip :-)

Yesterday I found some threads on the raspberry forums that suggested that overclocking the pi did help. I did not notice any improvement while overclocking to the medium setting.

- Magnus


Sorry I missed some letters, I meant "capable", sometimes I am typing too fast.
Anyway, that test that you did was what I wanted.

I have now pushed an mpeg audio header parser to my git.
But it should not affect the ac3 playback.

In the moment I do not drr problems with the lipsync using your sample.
What I do not understand....



Sorry I did not read your post carefully enough.
QuoteYes setting the "AC3 HDMI Mode" setting from "PassThrough" to "PCM" did improve playback
Since sounds like a delay of your tv or amplifier (please post how your vomp is connected).
You might need to adjust delay time at your tv or amplifier.



I have tested with the latest commits from the vompclient-marten repository for the last couple of days and there is no detectable lipsync problems on various channels that we have watched.

Just to clearify my setup. The raspberry pi is connected via hdmi to the tv only so sound is via hdmi directly to the tv.
The last couple of days testing has been done with SD Deinterlacing set to Advanced and AC3 HDMI Mode set to PCM.

I got some issues though with occasional audio break up's  some as long as lasting a couple of seconds while watching live tv on 720p channels.. Will open a new thread for this.


Ok, sounds like a delay by the ac3 decoder of your tv in passtrough mode, you can probably change a delay somewhere in your tv settings.