Poll

Server cvs-20080613 & client cvs-20080614, does it work?

Yes
2 (25%)
No, crashes / freezes with live tv
6 (75%)
No, but I'm trying it on a D3A ...
0 (0%)
No, other bug
0 (0%)

Total Members Voted: 8

Voting closed: June 22, 2008, 14:41:31

Author Topic: Testers Needed!  (Read 57604 times)

Offline carsten

  • Full Member
  • ***
  • Posts: 66
    • View Profile
    • Email
Re: Testers Needed!
« Reply #15 on: June 05, 2008, 19:20:46 »
Hi,

so far so good, I managed to compile the cvs plugin and dongle. Wanted to load dongle only on my experimental
MVP (handled through the config entry to point to either dongle file). But: 0.2.8 dongle will not run with "0.2.9.rc1"
plugin, as it doesn't work with software client. Is this intentionally and do we have an idea how to easily run rc1 and
0.2.8 together with one server?

BR,
Carsten.

Offline muellerph

  • Full Member
  • ***
  • Posts: 136
    • View Profile
    • Email
Re: Testers Needed!
« Reply #16 on: June 05, 2008, 19:40:10 »
Maybe I got your question wrong.
I think you mean you have a normal 0.2.7 server and want to try the current dongle / client 0.2.8rc1 out of cvs.
Also the other way round 0.2.8rc1 serverplugin and 0.2.7 client.
Both for sure won't work, as the network protocol has changed fundamentally.

But I also have only 1 productive server. I managed the trick with another server in a virtual machine which gets all data from the normal server via streamdev-plugin. The server in the virtual machine has now the vomp-plugin from 0.2.8rc1.

I described already my setup in this forum.

Works like a charm. No problem with the family and also full flexibility for development.
Only negative sideeffects are:
- Switching channels is a bit slower (as it needs the roundtrip through streamdev-plugin)
- Live-TV and recording a program is not possible, as streamdev is 1 channel only at the same time
Both are not a problem for a dev environment.

Offline carsten

  • Full Member
  • ***
  • Posts: 66
    • View Profile
    • Email
Re: Testers Needed!
« Reply #17 on: June 06, 2008, 13:41:54 »
Moin,

Volltreffer! I will use your recomendations to further try out developments, whilst neither disturbing myself
and my wife in the livingroom nor my elder son with Marten's software client.

VDR is anyhow running under XEN in a media DomU, together with SAMBA and a DAAP mediaserver.

Thanks a lot.

Offline mentox

  • Jr. Member
  • **
  • Posts: 9
    • View Profile
Re: Testers Needed!
« Reply #18 on: June 06, 2008, 18:38:46 »
hey all,

can anyone build a dongel an load it up to download for such people who can't build one ?!

thanks :-)

Offline carsten

  • Full Member
  • ***
  • Posts: 66
    • View Profile
    • Email
Re: Testers Needed!
« Reply #19 on: June 06, 2008, 19:00:41 »
Send me your email to c a r s t e n < a t > s c h i e r s < d o t > d e and I could try to set up
the latest dongle and the plugin against debian vdr 1.6.0 from e-Tobi. BR Carsten.

Offline Lutz

  • Full Member
  • ***
  • Posts: 49
    • View Profile
Re: Testers Needed!
« Reply #20 on: June 06, 2008, 20:07:37 »
May I also...?
Lutz

Offline carsten

  • Full Member
  • ***
  • Posts: 66
    • View Profile
    • Email
Re: Testers Needed!
« Reply #21 on: June 06, 2008, 22:03:57 »
You've got mail. I have no idea, whether it will work for you, but why not...BR, C.

Offline Lutz

  • Full Member
  • ***
  • Posts: 49
    • View Profile
Re: Testers Needed!
« Reply #22 on: June 07, 2008, 08:11:12 »
Hi Chris,
I've just managed to install the precompiled dongle and plugin I've got from Carsten, works so far, but when I do some channel switchicng, the box freezes and needs a power cycle reboot.
The same was before, with V. 0.2.7, but not so often.
The box I'm actually testing with is Model E1.
Later I will try to compile the plugin itself on my machine, but Carsten is using the same version of VDR from Toby's repository, so this shouldn't be the reason...
Regards
Lutz

Offline Lutz

  • Full Member
  • ***
  • Posts: 49
    • View Profile
Re: Testers Needed!
« Reply #23 on: June 07, 2008, 11:54:27 »
Hi Chris,
I've now managed to compile the plugin for my system, but I can' get the makedevenv-script working; could you consider to offer an actual cvs-dongle for download, just to be shure to test with a right one?
Regards
Lutz

Offline Lutz

  • Full Member
  • ***
  • Posts: 49
    • View Profile
Re: Testers Needed!
« Reply #24 on: June 07, 2008, 15:44:59 »
Hello Chris,
I just finished my own dongle, but no difference, I can switch a while, and suddenly while switching it freezes, exactly whilst hitting  the button. Sonmetimes OSD continues
to work  a moment, most times I just get the led flashing with the rc buttons...
I allways was thinking my network is OK...  I can easyly watch 6 streams or even more with the mvp, vomp on windows and vlc clients... no probs...
Cheers
Lutz

Offline MartenR

  • Hero Member
  • *****
  • Posts: 789
    • View Profile
Re: Testers Needed!
« Reply #25 on: June 07, 2008, 17:58:42 »
@Lutz
I get the same while heavyly testing the windows client code. At the moment I have no clue why this happens, I just see in the debugger that there is data transmitted and there is no streamreceiver present...

Marten

Offline MartenR

  • Hero Member
  • *****
  • Posts: 789
    • View Profile
Re: Testers Needed!
« Reply #26 on: June 08, 2008, 08:43:57 »
Some update I have trace it back. The origin is that, if you are doing heavily channel switching, there can be to request to the vdr at once, which is currently not supported in the plugin code.
So the client is waiting infinitely for a response of the server...
At the moment I am unsure, if this is a bug on the client side or if it should be added to the server side.
But may be I will supply a fix for this soon...
@Lutz
Do you have on the server side in the vomp log file:
[ERR]  RRProc  - recvReq err 1
?

Marten
« Last Edit: June 08, 2008, 09:34:18 by MartenR »

Offline MartenR

  • Hero Member
  • *****
  • Posts: 789
    • View Profile
Re: Testers Needed!
« Reply #27 on: June 08, 2008, 10:56:42 »
@Lutz
Here is a quick fix, please replace the attached files at the serverside and compile and build and tell me, if it is gone.

Marten

Offline Lutz

  • Full Member
  • ***
  • Posts: 49
    • View Profile
Re: Testers Needed!
« Reply #28 on: June 08, 2008, 17:31:01 »
@Marten

I don' find "[ERR]  RRProc  - recvReq err 1" in the vomp.log.

I've tried the files, but it doesn' t make a difference for me!

Lutz

Offline MartenR

  • Hero Member
  • *****
  • Posts: 789
    • View Profile
Re: Testers Needed!
« Reply #29 on: June 08, 2008, 17:37:02 »
@Lutz
Hmm, then it is a different error and my issue may be windows specific...
Since it does not crash on my machine anymore, the error is hard to guess...

Marten